Wanhao Duplicator D9 – MK10 Extruder issues – Teardown and….a 3D model

After having a few minor issues with filament slipping and prints generally being a bit crappy, I figured I’d take stuff apart, always helps me relax…

On the interwebs I was really unable to find any specific detail about the MK10 / MK11 type head that the Wanhao Duplicator 9 uses…

it’s quite similar, but different to the D6 one is about all I could find…

Unfortunatley D6 parts won’t fit….the D9 extruder block is a mirror image of the D6 one

Whilst dismantling the extruder, I discovered that the screw holding the lever arm was loose, which was causing issues with gripping the filament…

 

Whilst checking the extruder, I figured I’d pull the whole thing to pieces……………and measure it….and, learn a little basic CAD……….

 

I’ve put a STL of the whole extruder up on thingverse here….https://www.thingiverse.com/thing:3031179

 

thingverse extruder

I used Tinkercad to make the model….it’s not an elegant CAD package, BUT, it IS very easy to use and quite powerful….The model above probably took me about 15 hours all up, that’s including learning how to use Tinkercad…..those hours were spread out over a couple of weeks…If I started again, I recon I could get that down to about 6 hours!

Link to the tinkercad model...Please advise me of any issues found, measurements should be quite close on most things

https://www.tinkercad.com/things/fHYG5RUFZqI-wanhao-duplicator-9-d9-extruder-carriage-mk10

 

 

 

Author: bleughbleugh

Early Fourties, Wife, two kids in primary school. Both of us work full time...3 years now Back in Blighty after a decade away...It's a new country for everyone! Still finding time to tinker!

3 thoughts on “Wanhao Duplicator D9 – MK10 Extruder issues – Teardown and….a 3D model”

  1. Thanks for sharing your designs and findings on the D9. There is very little good info on this printer which I have had for 2 years already. It started out great and I’ve added a few of your parts to my printer (Very helpful, thanks). I now have an under extrusion problem due to slipping filament. My issue isn’t the screw but it rather seems to be the bearing that presses against the extruder gear. Not sure if you could offer any advice here? I am also in the process of upgrading to linear rails, again, you are the only post I can find on this! Thx AGAIN! Is it however necessary? Can one not just replace the wheels? I mean, It did print very nicely when it was new… Anyway, thanks for what you do and your efforts to post and explain everything you do in such detail, you are appretiated 🙂

    Like

    1. Hi,
      Rails on the X aren’t really necessary but they do seem to make a difference.
      I actually did originally use new wheels, they worked great.
      For me , ordering 3 rails wasn’t much more than ordering two, hence fitting 3..

      The D9 extruder is a real basic thing, you can buy them from amazon etc, it’s very similar to the one used on the ender 3!! take out the assembly and remove the bearing, de-gunk it.

      If it’s slipping that badly it could also be a clog, you may need to remove the hot end and the thin ‘throat’ part and see what’s going on inside..

      Personally I will be changing my whole extruder over to a bondtech clone type,

      I just haven’t had time of late to ‘play’ with the D9 since i got my ender 3 which just works…

      Like

    2. As for rails on the moving bed / y axis…if you’re not seeing issues with wheels, great!

      But, the forces are wrong, the wheels won’t hold up for 100’s of hours. Rails (or a better carriage design) support the heavy bed correctly.

      If you check the cost of cheap rails vs the cost of good quality wheels, there’s not a huge amount in it!

      Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s